Currently the Apples devices that are compatible with HISY are Apple iOS 7.0 or later for Apple iPhone 4S, 5, 5S, 5C, 6, 6 Plus, 6S, 6S Plus, 7, 7 Plus. iPad 3rd & 4th Generation or later.

Posted in: HISY QUESTIONS